逆战小强辅助-remixos

ubuntu下载工具
2023年4月1日发(作者:硕鼠下载)

Ubuntu16.04环境上安装常⽤软件的⽅法

在Ubuntu16.04环境中安装常⽤软件的⽅法

1.在ubuntu16.04环境中修改IP,MAC和DNS:

/*卡设备,进⾏修改

sudogedit/etc/init.d/

sudoens33dowm

sudoens33hwetherxx:xx:xx:xx:xx:xx(mac地址)

sudoens33up

-----但是好像重启后就有字段修改了⽹卡地址*/----忽略这个这个吧

通过下⾯设置,可完成ip,mac,dns的修改

sudogedit/etc/network/interfaces

修改如下:

autolo

ifaceloinetloopback

autoens33

ifaceens33inetstatic

pre-upifconfigens33hwetherxx:xx:xx:xx:xx:xx(mac地址)

addressx.x.x.x(ip地址)

netmask255.255.0.0

gatewayx.x.x.x

保存后,需要PC再查看ifconfig就发现ip和mac是更改了的

-----也可以单独设置DNS、MAC地址

sudogedit/etc/

//设置的dns

2.使⽤Xftp往linux环境中上传⽂件,则buntu上必须先安装有ssh,安装和设

置SSH服务步骤如下:

最好是切换到root⽤户下sudosu

安装ssh-server

sudoapt-getinstallopenssh-server

●安装ssh-client

sudoapt-getinstallopenssh-client

●确认sshserver是否安装

ps–e|grepssh

/etc/init.d/sshstart

●扩展配置

SSH默认服务端⼝为22,⽤户可以⾃已定义成其他端⼝,如222,需要修改的配置⽂件为:

gedit/etc/ssh/sshd_config

把⾥⾯的Port参数修改成222即可

然后重启SSH服务:

sudo/etc/init.d/sshrestart

3.在本机安装Xshell,连接Ubuntu中的linux

●确保Ubuntu可以联⽹

●ssh服务启动了

●打开xshell,新建连接

●在【⽤户⾝份验证】下,输⼊⾃⼰linux操作系统下的普通⽤户名和密码,

之后【确认】-【连接】

4.连接xftp设置

设置如下

报错提⽰“找不到匹配的outgoingencryption算法”

●原因,是ssh登录本地终端缓存了相关的安全确认信息,远端的服务升级后,其对

应的加密算法均作了升级、修改,⽽本地的缓存安全信息并⽆更新,导致⽆法正常登录,提⽰:“找不到匹配的outgoing

encryption算法”

解决措施1:打开某个会话的属性(在某个会话上右键-属性)

选中aes192-ctraes128-ctraes256-ctr

●正常连通

5.安装软件Emacs24

安装步骤如下:

1.确保⼀个⼲净的安装,请按照下⾯的步骤:(若安装了⽼版本的emacs,

删除)

sudoapt-getupdate

sudoapt-getinstall

sudoapt-getpurgeemacsemacs-snapshot-commonemacs-snapshot-bin-commonemacs-snapshotemacs-snapshot-el

emacs-snapshot-gtkemacs23emacs23-bin-commonemacs23-commonemacs23-elemacs23-noxemacs23-lucidauctex

apelemacs24emacs24-bin-commonemacs24-commonemacs24-common-non-dfsgemacs24-el

2.添加PPA

sudoadd-apt-repositoryppa:cassou/emacs

sudoapt-getupdate

3.安装

sudoapt-getinstallemacs-snapshot-elemacs-snapshot-gtkemacs-snapshot

sudoapt-getinstallemacs24emacs24-elemacs24-common-non-dfsg

6.安装Vim

sudoapt-getinstallvim

安装完成后,在命令⾏中敲⼊vi,tab键,可以查看显⽰有vim命令

修改vim配置,输⼊命令:sudovim/etc/vim/vimrc

InstallVimonUbuntu16.04

sudoadd-apt-repositoryppa:jonathonf/vim

sudoaptupdate

sudoaptinstallvim

removeVim8.0

sudoaptremovevim

sudoadd-apt-respository–removeppa:jonathonf/vim

7.安装wps2016

●⾸先在wps上下载linux的deb安装包;

●安装配置环境

sudoapt-getupdate

sudoapt-getinstalllibc6-i386

sudoapt-getinstallia32-libs(在64环境中安装不上这个,所以死活安装的wps有问题,不能使⽤)最后发现不能在ubuntu-64环

境中安装beta的安装包,重新下载Alpha包

●开始安装

sudodpkg–iwps-office*.deb(安装包路径和名称)

●若有依赖故障修复依赖

sudoapt-getinstall–f

卸载wps

●若是在UbuntuSoftwareCenter安装,直接在center中卸载;

●⾃⼰下载的deb安装,使⽤sudoapt-getautoremovesoftware-name;

●⼀次性卸载⼲净就使⽤sudoapt-getautoremove--purgesoftware-name(所

欲配置都卸载⼲净)

8.安装jEdit软件。(说明在安装jEdit前必须要安装jdk)

●下载jdk的安装包,进⼊JDK官⽹下载,java8下载地址:点击下载地址;

根据⾃⼰需要的环境进⾏选择下载,我⾃⼰下载的是:

●由于是在windows下载的,使⽤Xftp将安装包放到linux环境中,放在

⽬录/home/yourname/Downloads.

●解压⽂件:;解压后的⽂件夹所在⽬录为

/home/test/Downloads/jdk1.8.0_101

●将解压后的⽂件移动到/opt下:

cd/opt(切换到opt⽬录下)

mv/home/test/Downloads/jdk1.8.0_101/.(移动⽂件夹)

ls–l

●在/bin⽬录下创建java软链接(这个地⽅不太明⽩为什么要创建⼀个软

链接,可能是和下⾯设置环境变量有关系)

Root@test-virtual-machine:/opt#cd/bin

Root@test-virtual-machine:/binln–s/opt/jdk1.8.0_101/bin/javajava

●验证软件链接的正确性

Root@test-virtual-machine:/bin#java–version

●设置Java环境

Root@test-virtual-machine:/bin#gedit/etc/profile

若使⽤的是xShell,则会提⽰如下,所以这个地⽅的设置不能使⽤远程⼯具:

在⽂件最后编辑如下内容:

exportJAVA_HOME=/opt/jdk1.8.0_101

exportJRE_HOME=${JAVA_HOME}/jre

exportCLASSPATH=.:${JAVA_HOME}/lib:${JRE_HOME}/lib

exportPATH=${JAVA_HOME}/bin:$PATH

●更新/etc/profile⽂件:source/etc/profile

●验证安装情况

Root@test-virtual-machine:java–version

到⽬前为⽌jdk就安装成功了,再来安装jEdit

●下载jEdit安装包

下载地址:https:///doc//projects/jedit/files/jedit/5.3.0/

●下载后存在linux环境中,我⼀般下载后的⽂件都放在以下⽬录:

/home/test/Downloads(test为linux登录⽤户名字)

●进⾏安装

Sudodpkg–i/home/test/Downloads/jedit_5.3.0_

●安装完成后,输⼊命令jedit就可以启动jedit了

9.安装Evince

Sudoapt-getinstallevince

10.安装QT,参看⽹址:/doc//cddchina/article/details/50764791;和

/doc//moonclearner/article/details/49701207;

a)实际使⽤的环境:QTLibrary:5.7.0;QT安装包下载:

/download-open-source/

b)安装QTlibrary,下载的⽂件放在/home/test/Downloads,⼀般⽂件我都是

解压到opt下进⾏操作(后来才发现最好不要解压到opt下,直接解压就可以了)

cd/home/test/Downloads

–C/opt

解压后cd到解压的⽬录下cd/opt/everywhere-opensource-src-5.7.0

c)没有安装g++,编译QT要使⽤g++,⾸先安装g++

sudoapt-getinstallg++

d)安装libX11-devlibXext-devlibXtst-dev这三个包,若已配置就跳过

sudoapt-getinstalllibX11-devlibXext-devlibXtst-dev

e)上⾯的⽂件都安装了,直接进⼊qt-everywhere-opensource-src-5.7.0⽬录,

配置QTLibrary:

./configure

f)然后终端会出现让你选择商业版还是开源版,输⼊字母o选择开源版。

然后会有协议让你接受,输⼊yes就OK啦。

g)经过长时间等待,终端输出以下信息:

h)输⼊make这样⽣成QT库,同时编译所有演⽰程序

i)之后安装QT,命令:sudomakeinstall

j)长时间等待,安装完成后进⼊QT安装⽬录测试QT是否安装成功,默认安装在/usr/local/Qt-5.7.0⽬录下

cd/usr/local/Qt-5.7.0/bin

k)输⼊命令qmake,若出现正常信息,则表明QT以及安装成功,若出现以下情况,则还要继续。提⽰不存在/usr/lib/x86_64-

gnu/qt4/bin/qmake;

l)可能这个地⽅要疑惑了,我安装的是Qt5.7.0,并不是Qt4;就百度找原因,主要原因是:ubuntu系统本有qt4残留的⽂件,在

安装qt5后,⾃动安装了qtchooser。

m)解决⽅法如下:1.卸载了重新安装qt4(想想花了这么长时间在卸载,不愿意啊~~~~(>_<)~~~~)/usr/lib/x86_64-linux-

gnu/qt-default/qtchooser/在这个⽂件中有⼀个。更改你安装qt5的路径保存即可。(果断选择这

个⽅法)

修改上⾯的路径,修改为实际安装qt的路径:

/usr/local/Qt-5.7.0/bin

/usr/local/Qt-5.7.0

n)修改后再回到之前的地⽅:cd/usr/local/Qt-5.7.0/lib

Qmake–v查看版本(出现了证券的版本,表⽰安装成功了。是不是好激动,但是还没有设置完,不过胜利已经在望…)

o)配置环境变量,设置变量的⽬的是为了在任何⽬录下可以使⽤QT,⾸先设置⽤户环境变量:

gedit/home/yourname/.bashrc(test为登录的当前⽤户名)

p)在⽂件末尾添加以下代码:

q)设置root⽤户的环境变量,root⽤户需要root权限,⽤sudoSudogedit/etc/profile

末尾添加如下内容:

r)保存后退出,然后重启电脑,重启后在终端任意⽬录输⼊qmake,能看见正确信息,就表明环境变量已经配置成功。

s)安装QtCreator

sudoapt-getinstallqtcreator

安装完成后,在应⽤中搜索即可

t)也可以安装⼀些qt的帮助⼯具等

在Terminal中输⼊:sudoapt-getinstallqt4-dev-toolsqt4-docqt4-qtconfigqt4-demosqt4-designer

◆qt4-dev-tools中包括了QtAssistant,QtLinguist,QtCreator(貌似在

Ubuntu11版本中没有⾃动安装)

◆qt4-doc这个是帮助⽂档

◆qt4-qtconfigQt的配置⼯具,这个装好默认好

◆qt4-demos官⽅的⼀些Demo

◆qt4-designer可视化窗体设置⼯具

11.安装Eclipse(也需要安装好jdk,可以查看前⾯安装jdk的步骤)

●官⽹下载Eclipse安装包,存放在⽬录/home/test/Downloads下,解压到opt

⽂件夹下(我是解压到opt⽂件夹下的,后来发现/opt是系统⽂件夹,最

好⼀般解压⽂件不要解压在该⽬录下)

Sudocd/home/test/Downloads(来到Eclipse安装包⽬录下)

Sudotar–zxvfeclipse-jee-neon-R-linux-gtk-x86_–C/opt(标黄⾊部

分是安装包的名字)

●创建快捷⽅式

1.在终端执⾏如下命令sudogedit/usr/share/applications/p

2.编辑内容如下:(注意更改响应的名字和⽬录)

[DesktopEntry]

Name=Eclipse

Type=Application

Exec=/opt/eclipse/eclipse

Terminal=false

Icon=/opt/eclipse/

Comment=IntegratedDevelopmentEnvironment

NoDisplay=false

Categories=Development;IDE;

Name[en]=Eclipse

3.启动Eclipse即可,若新建⼯程卡死,尝试⼀下解决⽅法:

a.打开终端terminal然后输⼊以下指令:exportSWT_GTK3=0

b.进⼊eclipse的⽬录下,⽤gedit打开⽂件,对其进⾏如下

修改:

cd/opt/eclipse

c.在下⾯这⼀⾏的前⾯--Vmargs添加如下两句语句:

--_version

2

d.接下来应该可以完美运⾏了。

●移除系统⽂件夹opt下的⽂件夹

sudorm–rXXX(⽂件夹名)

sudormXX(⽂件名)

12.安装Bluefish

sudoapt-getupdate

sudoapt-getinstallbluefish

13.安装NetBeans(安装前必须安装jdk)

1.在官⽹中下载NetBeans的安装包

2.将下载的包放在Downloads⽂件夹下,运⾏如下的命令,使安装包变成

可执⾏状态

chmod+x~/Downloads/

3.下⼀步,运⾏下⾯命令开始安装

sh–c“~/Downloads/”

4.之后根据界⾯安装向导操作,知道安装完成即可

14.安装ZendStudio(参看⽹址:/doc//liuzhang/p/

和/doc//weishuan/p/)

●到官⽹下载安装包

●安装前请先安装java

●将安装包解压到安装⽬录下(/usr/local)

Cd/home/test/Downloads(这是我的安装⽬录)

Sudotar–.x86_–C/usr/local

●创建桌⾯⽅式(/usr/share/applications这个⽂件夹是桌⾯程序快捷⽅式所

在的⽂件夹)

Sudogedit/usr/share/applications/p

输⼊内容如下:

[DesktopEntry]

Name=ZendStudio13.5

Comment=ZendStudio13.5

Exec=/usr/local/ZendStudio/ZendStudio

Icon=/usr/local/ZendStudio/

Terminal=false

Type=Application

Categories=Application;Development;

●进⾏破解

1.⾸先是下载破解⽂件

2.将破解⽂件夹的er_1

3.5.1.v20160705-133

拷贝到

ZendStudio⽬录下plugins⽬录

cp–r~/er_

/usr/local/ZendStudio/plugins(可以打开指定⽂件夹进⾏检查是否拷贝

成功)

3.之后再启动ZendStudio,输⼊破解⽂件夹下对应的注册码就可以了

●破解完成后就可以使⽤了

15.安装程序sudoapt-getinstall**时出错:

出现这个问题可能是有另外⼀个程序正在运⾏,导致资源被锁不可⽤,主要原因可能是安装程序没有正常完成,进⽽出现这个

情况,解决⽅法如下:

sudorm/var/cache/apt/archives/lock

sudorm/var/lib/dpkg/lock

16.安装OpenOffice

1.⾸先就是卸载ubuntu系统中⾃带的libreoffice

⽅法⼀:Sudoapt-get–pregeremovelibreoffice*(卸载⼀个已安装的软件包,不报了配置⽂件)

⽅法⼆:在软件应⽤中⼼卸载,⽐较慢

2.解压⽂件,准备安装

tar–xzvf*.(安装包)

3.解压后,查看⽬录

4.安装OpenOffice,进⼊/en-US/DEBS⽬录下,执⾏命令安装所有的*.deb

安装包

sudodpkg–i*.deb

5.继续安装菜单项,进⼊/en-US/DEBS/desktop-integration⽬录下,安装deb

即可

sudodpkg–ideb安装包名称

6.此命令完成后,若没有错误,就表⽰openoffice以及安装完成,默认会安

装在/opt下

7.启动openoffice服务(似乎也可以不设置)

cd/opt/openoffice4/program

执⾏soffice-headless-accept=”socket,host=127.0.0.1,port=8100;urp;”

–nofirststartwizard&

8.查看openoffice默认的服务端⼝是否正常启动,输⼊命令netstat–tln

更多推荐

ubuntu下载工具